Turkish.co.uk
Back to incident history
Monitoring incident detected

Started

Ongoing

Duration

15 days

InvestigatingCRITICAL impact
Affected:Eastern EuropeWestern EuropeSouthern AfricaWestern AsiaNorthern AfricaMicronesiaSouth AmericaMelanesiaAustralia & New ZealandNorth AmericaCentral AsiaEastern AsiaMiddle AfricaCentral AmericaWestern AfricaPolynesiaSouthern AsiaEastern Africa

Update timeline

Investigating

We are investigating issues with Eastern Europe, Western Europe, Southern Africa, Western Asia, Northern Africa, Micronesia, South America, Melanesia, Australia & New Zealand, North America, Central Asia, Eastern Asia, Middle Africa, Central America, Western Africa, Polynesia, Southern Asia, Eastern Africa.

Monitoring incident detected — Turkish.co.uk Status